Updated 2022.09.19

  • Applicable products: SwitchBot Hub Mini
  • SwitchBot app version: 6.14.1 or newer

1. Make sure your SwitchBot app version is up to date.

2. Make sure the Hub Mini is connected to a stable 2.4GHz (802.11b/g/n, iPv4) WiFi network instead of a 5GHz one. Currently, the iPv6 network and Wi-Fi 6 router are not supported.

3. In many cases, it helps to fix the connection issue by unplugging the power cable of the Hub Mini for 10 seconds and then plugging it back in.
4. If it doesn't work, It is recommended to perform a test by connecting the Hub Mini to a Personal Hotspot from another mobile phone. Pay attention to the following points:
  • Turn on Personal Hotspot from another mobile phone.
  • If possible, turn off the Wi-Fi router to exclude disturbances during the test.
  • For iPhone 12 or newer devices, enable Maximize Compatibility to ensure the personal hotspot is a 2.4GHz network.

mceclip0.png

5. After the personal hotspot is enabled, follow the steps to proceed your test.

  1. Tap the Hub Mini on SwitchBot App.
  2. Tap the gear icon ⚙️ on the top right corner.
  3. Tap Wi-Fi Settings.
  4. Tap Edit, enter the new name & password of personal hotspot on your mobile phone.

mceclip1.png

6. If the Hub Mini is fine connecting to a Personal Hotspot, then the problem may be in the settings of your WiFi router. 

If it doesn't work, Please submit a feedback.

Send feedback

To receive a technical help from SwitchBot support team, follow these steps: 

On your same device, Go to SwitchBot app > Tap Profile > Tap Feedback > Select the product (which you need support for) > describe the issue in detail (with media if needed) as follows:

  1. Router brand and model:
  2. Mobile device model:
  3. Mobile device system:
  4. SwitchBot app version:
  5. Any other screenshot about the error message:

Comments

0 comments

Please sign in to leave a comment.