Can't finish/save calibration for SwitchBot Curtain


I am trying to finish the calibration but it is not working. It did once but now it keeps not saving the calibration settings.

I can start the calibration (Move curtain to open position -> Pause -> Next -> move curtain to closed position -> Pause -> Next) but when I reach the window to check the calibaration (the one with the 4 Buttons "Recalibrate fully opened"; "Move to fully open"; "Recalibrate fully closed"; "Move to fully closed") the buttons "Move to fully open" and "Move to fully closed" can be pushed but nothing happens.
When I use the "Recalibrate fully opened" and "Recalibrate fully closed" buttons I can move the Bots again and afterwards click on the button "Finish" but the calibration is not saved and I can't move the Bots afterwards with the standard buttons to do so. Also when I go back to the "Home" screen and select one of the curtains it directly comes up with "The device is not calibrated....".

Please help.




  • Hi there,

    We are sorry for any inconvenience caused. We believe the issue was caused by the fact that the calibrated data was not uploaded to the server yet. You did the calibration correctly, but when you finished and went back to the homepage, you can try to pull down to make a refreshment and let the calibration data upload to the server quicker. 

    If you find this not help with the calibration issue, please kindly contact with a relevant video that shows the problem, the support team will help you furthermore.

    SwitchBot Team

  • Hi Switchbot Team,

    I’m currently having the same issue but I’ve tried all that was suggested above and even made sure everything was updated and it still won’t save/remember the calibration. I even tried uninstalling app and repairing everything as well, same result. How else can I go about this?
    Thanks for the help in advance.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post