Unknown Error 190

Not sure if this is the right place to post this but I am frequently getting "Unknown error (190)" in my hub log and have to repeat the command for the hub to execute.  This is happening both with SwitchBot and the Curtain.  If I repeat command if most often works second time.  This is happening when using Siri shortcuts both spoken and pressed in the shortcuts apps. 

0

Comments

10 comments
  • Official comment

    Dear customer,

    We understand that the SwitchBot Bot in your home didn’t run correctly and it is annoying to you. Would it be convenient for you to submit a feedback from the app’s Profile page so that we can investigate into your device and see if we can do anything about it? Thank you very much for bringing up the problems and we will do our best to fix them.

    Sincerely,

    SwitchBot Team

  • I also am getting an unknown error (190) in my log.  The problem is that I have set up my two switch bots but when I try to use them they do not work. It says that it could not connect to the device and move closer. I have the 2 switch bots sitting right next to my phone, hub and router. I can't get any closer. I am able to do the setup and the mechanism work during setup. It is only during the actual usage of the switch bot that they will not work.

    0
  • Hi, I would like some answers as I am also dealing with the error 190 for all my switchbots, for well over 3 months. I have already submitted at least 3 different feedback mails from the app itself, with different control factors (with an older version of the app, with a different switchbot, with BLE/Wifi/4G, etc.) respectively, and yet receive neither success nor response whatsoever.

    To elaborate a little, I can see them functioning when trying to add them as new devices (none of them work now with the same error), but once they are on my device list I can no longer control them by all methods I can imagine (the same problem as Mark.)

    I liked the device very much, but now they constantly remind me to rely less on smart home devices.
    I do appreciate novel things with nice devs that try to innovate. Please, I am waiting for your response mail for several months. 

    0
  • I have been fighting this problem too. Solutions seems to be to power on reset my switch hub mini. It’s annoying

    1
  • Jeff, me too.

    0
  • Hi

    I have 3 black units, have integration to home assistant via IFTT and has the switchbot wifi hub 

    I got the Error code 190 via the app and error code 161 via IFTT  in one of my units. It is relating to low power so change the battery and all good. You will see in this case when you go to this specific switch some settings are disabled namely- password, mode, schedule and also firmware & battery. this is an indication  that battery is weak 

    This is not the first time it happened and it happened to other 2 as well in the past

    0
  • I get this a lot - both errors 190 and 161. My hub is about 3m away form the curtain bots, in the same room and in direct line of sight. Doesn't see to be any discernible reason for it.

    0
  • Yeah, this is definitely a problem.  I have an Alexa routine that pushes a button, and then about 40 seconds later hits that same button again.  If it misses it the first time because of communication, no biggie, can reset and try again.  BUT, if you get a 190 on it like I did on the second one only, it's a major issue.  It turns on the flow of water from a bottle refilling a pet dish.  GF ran the routine and walked away because it hasn't not worked before.  Well, long story short is she is downstairs trying to dry off a wooden bedroom floor that got drenched because it doesn't work.  Hoping there wasn't any real damage besides a lot of wasted water.

    Seeing these comments I'm thinking Switchbot may not be reliable enough for this task.  Unfortunately it's simply a push button and not a switch, so there is no way to run the "off" multiple times in sequence as a failsafe since it would just toggle it.

    Can anyone from Switchbot comment on this?  I love the fact the product exists, but reliability within a short window doesn't seem like too much to ask for.

    0
  • Scott, I think you have answered your own question there. Unless the Switchbot Bot control becomes "closed loop" like many other smart home devices are, then it's never going to be robust enough for safety or damage-critical applications such as yours. Don't forget that anything wireless can be affected by external factors too. So even though in most cases I don't doubt that the Switchbot hardware itself is at fault, even if they increase their reliability it could still fail for reasons beyond their control.

    FWIW for my curtain bots it is indeed possible to work around this by simply running the commands multiple times with a short time delay in between each, as the "open" and "close" commands are distinct, but it seems this is not an option with the Switchbot Bot.

     

     

    0
  • The Bot COULD do it in switch mode no problem.  I have two, one is the aforementioned one, and one is on a light switch.  The nature in switch mode would be fine.  But yeah, mine is in press mode, and that wouldn't work for me.

    I understand the issue and I knew it needed to be babysat when being used.  My GF, though, didn't realize it well enough I guess.  I'm actually adding a leak sensor into the system to try to prevent this from happening again.

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post