Last Updated: 2023 March 31

  • Applicable products: SwitchBot Hub 2, SwitchBot Hub Mini

1. Please ensure that your home's power outlet is functioning properly.

2. Ensure that the cable is securely plugged into the device.

3. If you have an alternate charging adapter and cable available, try switching to them to see if the device turns on. Once powered on, the Hub Mini will flash its indicator for a while, and Hub 2 will beep and display temperature and humidity data simultaneously.

Device Charging adapter output Connection port
Hub Mini 5V1A/5V2A Micro USB
Hub2 5V2A
USB Type C(with multiple sensors)

4. If using a different charging adapter and cable resolves the issue, we will compensate you for the cost of the charging adapter/cable in the case of the Hub Mini. The Hub 2 cable is unique and will be replaced with the original or a new cable within the warranty period.

5. If the device fails to turn on even after switching the charging adapter and cable, please contact us by logging in to the SwitchBot app → Profile → Help and Feedback → Feedback. We would appreciate it if you could provide us with the following information when you contact us.

  • Please kindly provide us with a video of the device failing to start after powering on.

Comments

2 comments

  • rosnow

    How do we send the video??

    0
  • cuzme

    i have same comment ...followed instructions on the links ...wasted time writing on small cell screen what problem is

    (device failure HUB2) then after all that asks for video...did upload as set up ...but then next screen says upload failed? and to go back to bla bla but then go back is not prior screen? or any shown as "pending/in progress" ? one to try to upload again!

    Soo getting some frustrated as tried it 2 times have to re type on small cell screen again and get same result??

    Do you have a on web section to do this with, would appreciate some assistance!

    thanks,

    Patrick

    0

Please sign in to leave a comment.